a "problem" with nikon d90 pop-up flash
PhotoCamel: Your friendly photo community, with free discussion forums, digital photography reviews, photo sharing, galleries, downloads, blogs, photography contests, and prizes.
 

Go Back   PhotoCamel - Your Friendly Photography Forum > Cameras and Lenses > Nikon

Reply
 
LinkBack Thread Tools Display Modes
Old 08-02-2009   #1
Llama
 
Location: Romania, CT
Posts: 740
CamelKarma: 155965
Editing OK?: Yes
Constructive Critique?: Yes
Default a "problem" with nikon d90 pop-up flash

hey, all!
i recently upgraded from d70 to d90, and i must say that there is a HUGE difference between these 2 cameras. HUGE!
Anyway, all good till today, when i went to photograph some insects. I use a home made extension tube and the 50mm 1.8 for that. When i tried to command my sb-600 with the pop-up flash, it won't work. the flash rectangle and the flash exposure compensation keep blinking on the top lcd, and the shutter release button is locked. Now, i looked in the camera's menu, and i did try to set the pop-up flash in tll and in the manual and even in the -- mode as a commander, but i still won't work.
Can someone help me, please?
I repeat, the flash works when i put it on manual power, and the sb-600 mounted on the camera works too (only tried it on manual power).

__________________
Members don't see ads in threads. Register for your free account today and become a member of PhotoCamel to open up the site's many benefits and features.
__________________
Nikon d7000;Nikkor 35mm f/1.8; Nikkor 18-70 f/3.5-4.5, Sigma 55-200mm D f/4.5-5.6, nikkor 50mm 1:1.8, sigma 105mm f/2.8 macro and the lovely Sigma 10-20 f/4-5.6.
Slik Pro 330 DX tripod
my photoblog: http://emtee-photography.blogspot.com

comments welcomed, critics even more.
thebeing is offline   Reply With Quote
Old 08-02-2009   #2
F1 Camel
 
Eero Makela's Avatar
 
Location: Toronto
Posts: 4,410
CamelKarma: 8600328
Editing OK?: Ask First
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

Try with normal lens attached, (ie without home made extension tube)
will the popup trigger the SB600 then.

My guess is that the camera needs the communication from the lens contacts to feed info before it can trigger flash.
__________________
Eero Makela
Photographies des femmes pour les hommes.


Eero Makela is offline   Reply With Quote
Old 08-02-2009   #3
Llama
 
Location: Romania, CT
Posts: 740
CamelKarma: 155965
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

it works without the extension tube perfectly. i don't quite see why it should get info from the lens to trigger a remote flash (NOT set on ttl). I don't see any reason to make the camera do that.
Thanks nikon for taking out this very useful feature and sticking in video-crap.
nikon seems to suck more and more.
__________________
Nikon d7000;Nikkor 35mm f/1.8; Nikkor 18-70 f/3.5-4.5, Sigma 55-200mm D f/4.5-5.6, nikkor 50mm 1:1.8, sigma 105mm f/2.8 macro and the lovely Sigma 10-20 f/4-5.6.
Slik Pro 330 DX tripod
my photoblog: http://emtee-photography.blogspot.com

comments welcomed, critics even more.
thebeing is offline   Reply With Quote
Old 08-02-2009   #4
Vicuna
 
Posts: 199
CamelKarma: 5841
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

Did it work the way you want with your D70? I agree with Eero Makela about the lens to camera to flash communication.

You say the flash is not in TTL mode. What mode are you using? Try manual (M) mode on the flash, manual (M) on the camera, set your desired f stop and shutter speed and then adjust the flash output power as necessary on the back of the flash.

With this technique there is no communication required except from your brain to the camera and flash controls. By doing it this way you will get a lot of satisfaction and feeling of accomplishment when you get a good image.

I use my D200/SB-800 in manual mode for most of the stuff I do and the results are usually better than the automatic functions that can easily be fooled.
__________________
Bob - West Chester, Ohio (Southwestern Ohio area)
Use the preview feature to proof read your post to see if you any words or letrs out. You can check any links you embedded to see if they work properly
Bob Stothfang is offline   Reply With Quote
Old 08-02-2009   #5
Llama
 
Location: Romania, CT
Posts: 740
CamelKarma: 155965
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

i mostly use the M mode for shooting and, except times where light conditions change too quickly, i ALWAYS shoot with the flash set on manual.
i had no problem using my home made extension tube on my d70 with the sb-600 off camera (actually, that's how i mostly used it, because the lumisphere gets into the 50mm and my images got foggy from the lightspill).
On the d90, when i put the extension tube on, i only can shoot with the pop-up flash or the sb-600 on-camera set to M mode. I am not an idiot, to complain why i don't have ttl when the lens doesn't actually touch the mount. I only want the pop-up flash to be able to command the sb-600, in MANUAL MODE. But the camera disables the flash, and, heck, it even disables the shutter, altough EVERYTHING IS ON MANUAL.
Now, if i take the extension tube out of the equation, and mount the lens on the camera, everything comes back to "normal". But that leaves me with no option of shooting macro (don't have a dedicated macro lens...yet).
What i don't understand is WHY the camera won't let me trigger the sb-600, altough, again, is set to go off at 1/8 or whater power, so, it's on manual power...
__________________
Nikon d7000;Nikkor 35mm f/1.8; Nikkor 18-70 f/3.5-4.5, Sigma 55-200mm D f/4.5-5.6, nikkor 50mm 1:1.8, sigma 105mm f/2.8 macro and the lovely Sigma 10-20 f/4-5.6.
Slik Pro 330 DX tripod
my photoblog: http://emtee-photography.blogspot.com

comments welcomed, critics even more.
thebeing is offline   Reply With Quote
Old 08-02-2009   #6
Photocamel Master
 
Dirk's Avatar
 
Location: Netherlands
Posts: 7,564
CamelKarma: 901196
Editing OK?: Ask First
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

not every progress is indeed a progress.

did you check the syncspeed ?
everything manual > means body swithc from af to M , lense on M , jogdial on M , flash on M shure to check them all ?

what extention tube are we talking about?
__________________
Life is too short to miss a picture
Dirk is offline   Reply With Quote
Old 08-02-2009   #7
Llama
 
Mithras's Avatar
 
Location: Nebraska, USA
Posts: 519
CamelKarma: 8577
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

It seems that every time I try to use my SB600 off camera with the camera in commander mode I always forget to set the SB600 to wireless mode.

Have you checked to make sure the flash is set to wireless mode?
__________________
"The question is not what you look at, but what you see." ~Henry David Thoreau
Mithras is offline   Reply With Quote
Old 08-03-2009   #8
Llama
 
Location: Romania, CT
Posts: 740
CamelKarma: 155965
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

Quote:
Originally Posted by Dirk View Post
not every progress is indeed a progress.

did you check the syncspeed ?
everything manual > means body swithc from af to M , lense on M , jogdial on M , flash on M shure to check them all ?

what extention tube are we talking about?
i didn't switch the AF lever, and i really hoped, when i read your post, that THAT was the problem.
Tried it again.
So,
AF switch to M - check
Shooting mode to M - check
Pop-up flash as a commander, groupA channel3 set on M power, at 1/8, remote sb-600 set on wireless - check.
The lens i am using is the 50mm 1.8, which does not have a A/M switch.
And, the extension tube...well, it's one i made, from a body cap, a rear lens cap and some tube inbetween. it's this http://photocamel.com/forum/macro-cl...sion-tube.html but a bit improved.

One more thing i just noticed...in the top LCD, the metering type icon dissapears, aswell as the shutter speed (aperture is FEE, since no lens is mounted directly on the camera) and the flash info rectangle keeps flashing. When i press the flash down, metering appears, aswell as shutter spped and Fee.
__________________
Nikon d7000;Nikkor 35mm f/1.8; Nikkor 18-70 f/3.5-4.5, Sigma 55-200mm D f/4.5-5.6, nikkor 50mm 1:1.8, sigma 105mm f/2.8 macro and the lovely Sigma 10-20 f/4-5.6.
Slik Pro 330 DX tripod
my photoblog: http://emtee-photography.blogspot.com

comments welcomed, critics even more.
thebeing is offline   Reply With Quote
Old 08-03-2009   #9
KmH
Guest
 
Posts: n/a
CamelKarma:
Default Re: a "problem" with nikon d90 pop-up flash

Is the SB-600 also set to channel 3?
  Reply With Quote
Old 08-03-2009   #10
Llama
 
Location: Romania, CT
Posts: 740
CamelKarma: 155965
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: a "problem" with nikon d90 pop-up flash

everything was set the way it should be. i've shot many photos like this, with my d70. that's why i'm concerned why it doesn't work on my new d90.
yes, the flash is set on grA, ch3, aswell as the commanding option of the pop-up flash.


__________________
Members don't see ads in threads. Register for your free account today and become a member of PhotoCamel to open up the site's many benefits and features.
__________________
Nikon d7000;Nikkor 35mm f/1.8; Nikkor 18-70 f/3.5-4.5, Sigma 55-200mm D f/4.5-5.6, nikkor 50mm 1:1.8, sigma 105mm f/2.8 macro and the lovely Sigma 10-20 f/4-5.6.
Slik Pro 330 DX tripod
my photoblog: http://emtee-photography.blogspot.com

comments welcomed, critics even more.
thebeing is offline   Reply With Quote
Reply

« PhotoCamel - Your Friendly Photography Forum > Cameras and Lenses > Nikon »


Share this topic:

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Contrast problem with PE 7 in "save for web" pardes Image Editing 3 04-22-2009 01:12 AM
Filter comparison "none" " UV" " 81A" and "polarize" . dvdowns Camera Accessories 8 06-25-2008 08:24 AM
Problem with "User Define" Epson 1800 trinicapone Printing Images 3 03-19-2008 05:57 AM
3 flash indoor portrait "studio" Uncle Frank Lighting Technique 13 03-13-2008 02:03 PM
Problem with "My Threads" Loa Suggestions / Questions 3 08-17-2007 07:25 PM