Exposure problems with the Fujica ST 901!
PhotoCamel: Your friendly photo community, with free discussion forums, digital photography reviews, photo sharing, galleries, downloads, blogs, photography contests, and prizes.
 

Go Back   PhotoCamel - Your Friendly Photography Forum > Cameras and Lenses > Film Camera

Reply
 
LinkBack Thread Tools Display Modes
Old 06-12-2016   #1
Alpaca
 
Posts: 3
CamelKarma: 10
Editing OK?: Ask First
Constructive Critique?: Yes
Default Exposure problems with the Fujica ST 901!

Hi, I got my hands on a minty fresh Fujica ST901, really good condition.
The manual shutters are all correct, no corrosion in the battery compartment, the matte screen and mirror looks clean.

But the Auto function doesn't measure correctly, at all!
Sometimes it measures 1-20 seconds in bright sunshine, sometimes 200th.

I'm using a V4034 battery.
Can this be solved?

Thanks!
/ Richard

__________________
Members don't see ads in threads. Register for your free account today and become a member of PhotoCamel to open up the site's many benefits and features.
Guttan is offline   Reply With Quote
Old 06-12-2016   #2
F1 Camel
 
blumesan's Avatar
 
Posts: 3,040
CamelKarma: 661924
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: Exposure problems with the Fujica ST 901!

Do you have access to a camera manual? If not, see here: http://www.butkus.org/chinon/fujica/...jica_st901.htm
Is the V4034 the correct battery for this camera?
__________________
My Gallery
blumesan is offline   Reply With Quote
Old 06-12-2016   #3
Alpaca
 
Posts: 3
CamelKarma: 10
Editing OK?: Ask First
Constructive Critique?: Yes
Default Re: Exposure problems with the Fujica ST 901!

Quote:
Originally Posted by blumesan View Post
Do you have access to a camera manual? If not, see here: Fujica ST901 instruction manual, user manual, PDF manual, free manuals, instruction guide, user guide
Is the V4034 the correct battery for this camera?
Yeah I saw that, thanks!
From what I've gathered a 6volt 4lr44 battery is required, V4034 is exactly that.
Guttan is offline   Reply With Quote
Old 06-21-2016   #4
F1 Camel
 
Golem's Avatar
 
Posts: 2,791
CamelKarma: 683702
Editing OK?: Yes
Constructive Critique?: Yes
Default Re: Exposure problems with the Fujica ST 901!

Maybe the auto iris is very erratic and the shutter
times are actually appropriate for each random
stop-down of the iris. You don't mention the iris
and you don't mention any actual on-film testing.
Golem is offline   Reply With Quote
Old 06-22-2016   #5
Alpaca
 
Posts: 3
CamelKarma: 10
Editing OK?: Ask First
Constructive Critique?: Yes
Default Re: Exposure problems with the Fujica ST 901!

Quote:
Originally Posted by Golem View Post
Maybe the auto iris is very erratic and the shutter
times are actually appropriate for each random
stop-down of the iris. You don't mention the iris
and you don't mention any actual on-film testing.
The iris is fully manual!


__________________
Members don't see ads in threads. Register for your free account today and become a member of PhotoCamel to open up the site's many benefits and features.
Guttan is offline   Reply With Quote
Reply

« PhotoCamel - Your Friendly Photography Forum > Cameras and Lenses > Film Camera »


Share this topic:

Thread Tools
Display Modes